19 November, 2009

Spa Repair

As it is getting hotter in town, and after doing a water change last week, the spa developed a problem... The circulation pump, which actually pumps water through the filter, went 'belly-up'! So I took it out, and off I went to the Poll and Spa shop only to find out that, even though the parent company Monarch, had gone out of business, the circulation pump was actually a cheap Chinese import, and that a NEW one (that will not match existing plumbing OR union joints) will need to be sourced, grrrrrr!

So the search began (by the pool shop) to find a newbie, and I headed on my way. That was Tuesday. This morning though, with the temp heading north of 35 today and 40+ over the next two days, I got a call telling me my pump was in, an Aussie one and everything will match up, YEAH!

So I drove to the shop, and the first thing I saw was that the end of the electrical cable was wrong, but I think I can make do with that... Simply open up the electrical box and swap it for the one on the old pump, right? Simple? Sure was!!!

Old (left)_New (right), originally uploaded by AussiePomm.
Inside spa circ pump removed, originally uploaded by AussiePomm.
Spa Circuit Board, originally uploaded by AussiePomm.
Job Finished, originally uploaded by AussiePomm.

As you can see, the Supervisory Cat was on duty...

Watch Cat, originally uploaded by AussiePomm.

Whilst all of this was going on, me outside in the heat, where was Macc? Asleep of course (and I dare not startle him, as his head is UNDER the TV cabinet!

Sleepy Macc, originally uploaded by AussiePomm.


No comments:

Post a Comment

There are WAY to many spammers commenting, so unfortunately, I have now blocked annoymous commentors; sorry...

Approval should not take long, sorry!